This documentation relates to iSymphony 3.5. You can view older documentation on the Older Documentation page

Skip to end of metadata
Go to start of metadata

This document contains information that is important to note when upgrading to iSymphony 3.4.2. Please be sure to completely read the information before upgrading. 

If you are not upgrading from iSymphony 3.3.2, be sure to check the changelog and upgrade notes for previous versions as well.

End of Support Announcements

Support has been dropped for Asterisk version 1.8, 10, and 12 since iSymphony 3.3.x. iSymphony will continue to officially support Asterisk version 11 and 13.

Support has been dropped for Oracle JRE v1.7 since iSymphony 3.3.x.  If you are running Java 7, you will need to upgrade to Oracle Java 8 or above. See the Supported Platforms page for more details.

Support for Desktop Client 1.x has been dropped, Desktop Client version 2.x will be required from iSymphony Server v3.4.2 onwards. To use v1.x of the desktop client a previous version of the iSymphony Server using Module 2.0.0 or 1.x will be required.

Upgrade Steps

Follow the standard upgrade instructions found in the Upgrading iSymphony document for all upgrades. 

The desktop module is now included with the standard distribution to simplify the setup. When upgrading if you are using an older version of the desktop client it is strongly recommended that desktop client is upgraded to version 2.1 or later.

  • No labels