iSymphony repeatedly disconnects from Asterisk
Last modified by michaely on 2021/09/10 22:40
On this page
Symptoms
The iSymphony server repeatedly disconnects from Asterisk causing all clients to disconnect.
Cause
There are a few issues that could cause iSymphony to disconnect from the Asterisk server:
- Network Issues - If the iSymphony server is remote from the Asterisk server issues in the network can cause the connection to drop. Verify that no packets are being dropped and that there is no device in the network that would be resetting these connections.
- Socket Buffer Overflow - If Asterisk is sending to much information for iSymphony to process the kernel level socket buffer can fill up causing the socket to close. This usually occurs on high traffic systems. In order to determine if this is the case a packet capture must be done on TCP port 5038 on the iSymphony server side and must be inspected for TCP Window Full and TCP Zero Window flags which would indicate a socket buffer overflow.
- Write Timeout - If Asterisk is taking to long to write an event to the socket it will close the socket. This usually occurs on high traffic systems.
Resolution
The resolution depends on the cause of the disconnect:
- Network Issues - Resolve the issues on the network causing the packet loss or resets.
- Socket Buffer Overflow - The kernel level socket buffer sizes need to be increased to handle the bursts of traffic coming from the system.
Write Timeout - Add the following line in /etc/asterisk/manager.conf to the Asterisk manager entry that iSymphony uses to connect to:
writetimeout = 10000Then issue the following command in the Asterisk CLI
manager reload