Transfers in iSymphony fail to honor ring time settings and bypass voicemail when using Thirdlane PBX

Version 28.1 by Sean Hetherington on 2013/03/21 09:53
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Symptoms

When using a Thirdlane PBX call transfers via iSymphony seem to ignore ring time settings and bypasses voicemail failover.

Cause

When transferring via iSymphony the physical channel is transferred leaving the RINGGROUP_TIMEOUT variable set on the channel. When the tl-userexten context is hit it detects the presence of the RINGGROUP_TIMEOUT variable and passes the channel to tl-userexten-rg-base which does not contain the voicemail fail over logic causing the call to simply end.

Resolution

There are two solutions to the issue.

  1. Use device based ring groups. Since the variable never gets set the behavior will be exactly what you expected.
  2. Create a custom context that strips the variable first before sending it along.

    [from-inside-redir-isymphony]
    exten => _X.,1,Set(__RINGGROUP_TIMEOUT=)
    exten => _X.,n,Goto(from-inside-redir,${EXTEN},1)

    Next set the redirecting context in the iSymphony tenant configuration to "from-inside-redir-isymphony"

     

See http://www.thirdlane.com/forum/isymphony-error-when-forwarding-calls for more information

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