Java Web Start Launcher has stopped working Java 7 Update 7

Last modified by michaely on 2021/09/10 22:40

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Symptoms

When installing or launching the iSymphony client from the launch.jnlp file (or from the desktop icon) you get an error message "Java(TM) Web Start Launcher has stopped working":

jws_7u7_exception.png

When the problem details are clicked on, you'll see the exception code "c0000417"

jws_7u7_exception_code.png

Cause

Java 7 Update 7 appears to have a known issue with the "javaws.exe" executable that causes a crash in the Java Web Start launcher preventing the installation from continuing or full launch to occur.

Workaround

Information

This workaround will disable the auto population of the profile location and tenant with FreePBX systems.

Open the following file on the server in your preferred editor. Make sure to create a backup of the file:

/opt/isymphony/server/client/launch.jnlp

At the top you will see a line that looks like the following:

<jnlp spec="1.0+" codebase="#CODEBASE#" href="launch.jnlp?location=#WIZARDSERVERLOCATION#&amp;tenant=#WIZARDSERVERTENANT#">

Modify it to look like the following and save the file:

<jnlp spec="1.0+" codebase="#CODEBASE#" href="launch.jnlp">

Resolution

  • Upgrade to iSymphony version 2.7.0 rev. 3983 or higher. See the iSymphony 2.7.0 Release Notes for more details.
  • Downgrade to Java 6, Update 35 or higher.
  • Note that the workaround above may also be considered a fix if you do not require tenant and server auto-population but may need to be applied after any iSymphony server upgrade.

 

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