iSymphony JNLP client will not launch after upgrading Java to 1.7.0_51

Last modified by michaely on 2021/09/10 22:40

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Symptoms

After an upgrade to Java 1.7.0_51 the launcher will mention that Java does not allow self signed application to run.

Cause

Java 1.7.0_51 no longer allows self-signed JWS applications from running. iSymphony 2.8.1 and below are self signed applications.

Resolution

Upgrade to iSymphony 2.8.2+ which is now signed via a valid certificate authority.

If you can access the iSymphony client Administration Interface you can update using the Automated Update Instructions in the Updating guide.

If you cannot access the client you will have to use the following commands to update the server via the iSymphony CLI.

telnet localhost 50001
check_for_updates
update

You can type update_state in the iSymphony CLI to check on the status of the update.

After running the update command you will be droped back down to the iSymphony prompt while the update is downloaded. Once the download is compete you will be kicked out of the iSymphony CLI as the iSymphony Server is restarted for the update to apply. After a few minutes log back into the iSymphony CLI via the command telnet localhost 50001 and then type version to check that the server update was successful and you are now running the correct version. If the version is reporting correctly the update was applied and you can restart your clients to update the client files.

 

If the version is not correct and the update did not seem to apply run the following commands to install the update manually.

cd /opt/isymphony/server/update/server
chmod +x install.sh
./install.sh

Next restart the server based on the type of installation you have.

RPM

 service iSymphonyServer restart

TAR

/opt/isymphony/server/shutdown.sh
/opt/isymphony/server/startup.sh

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