Desktop Client V2 cannot connect to iSymphony server and cannot be downloaded from web interface
Problem
The desktop client can't connect to iSymphony even though the correct hostname and port are configured.
In addition to the above issue the desktop client cannot be downloaded from the iSymphony web client.
Cause
If the host name and port are indeed correctly configured, this problem is caused by an incorrect desktop client module on the iSymphony server. The wrong version of the desktop client may be installed or missing it is be missing entirely.
Solution
This problem can be resolved by (re)installing the correct desktop client module on the iSymphony server
Versions 3.4.2 and higher
You may want to use a panel to highlight important steps.
- connect the (remote) shell of the iSymphony server
- stop the iSymphpony server
service iSymphonyServerV3 stop - remove current desktop module
rm -rf /opt/isymphony3/server/modules/desktop - Download the iSymphony server tar for the currently installed version
cd ~/
wget <URL from Download archive> - extract desktop module from tar into iSymphony's module directory
{{tar -C /opt/isymphony3/server/ -xvf <downloaded file>.tar modules/desktop}} - Check ownership of the module
See: Desktop Client Module Installation
- Start iSymphony
{{service iSymphonyServerV3 start}}
Version 3.4.1 only
Since the desktop client module is include for versions 3.4.2 and higher, It is highly recommend to upgrade iSymphony to the latest 3.4.x version instead of repairing the module by the following steps:
- connect the (remote) shell of the iSymphony server
- stop the iSymphpony server
service iSymphonyServerV3 stop - remove current desktop module
rm -rf /opt/isymphony3/server/modules/desktop - Follow the regular instructions
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