Failed to authenticate with the iSymphony server
Last modified by colinw on 2021/09/10 22:40
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Symptoms
When using the iSymphony 3 FreePBX module, the server status shows as disconnected, with the following error message:
Failed to authenticate with the iSymphony server.
Verify that the "Server API Username" and "Server API Password" below are correct.
Also verify that you have a proper realm auth user defined in the iSymphony server's security.xml file for the communication_manager servlet security settings.
Verify that the "Server API Username" and "Server API Password" below are correct.
Also verify that you have a proper realm auth user defined in the iSymphony server's security.xml file for the communication_manager servlet security settings.
Cause
The username and password that the FreePBX module is using to configure the iSymphony server are incorrect, or no user has been defined.
Resolution
Open the file /opt/isymphony3/server/conf/security.xml
Find the following block of code:
<SecurityContext servlet="communication_manager" enabled="true">
...
<RealmAuth enabled="true">
<RealmAuthUsers>
<RealmAuthUser username="<username>" password="<password>" />
</RealmAuthUsers>
</RealmAuth>
...
</SecurityContext>
...
<RealmAuth enabled="true">
<RealmAuthUsers>
<RealmAuthUser username="<username>" password="<password>" />
</RealmAuthUsers>
</RealmAuth>
...
</SecurityContext>
Note the username and password from this section, and enter these into the FreePBX module section titled 'Server API Connection Settings'.