Not connected to Asterisk Server

Last modified by Scott Gagan on 2021/09/10 22:40

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Symptoms

You receive the following error message in the Profile Navigator when connecting to the server:

Unknown macro: noformat. Click on this message for details.

Or

Unknown macro: noformat. Click on this message for details.

 

Cause

This error is thrown when the server you are attempting to connect to does not have a connection to the Asterisk Server. There are a few things that can cause this to happen:

  • An AMI login is not configured in Asterisk.
  • The iSymphony server is not connecting to the AMI with the proper credentials.
  • A firewall is blocking communication with the AMI from the iSymphony server. 
  • The AMI login does not have a permit entry for the ip of the iSymphony server.
  • A bug in older versions of iSymphony caused AMI connection leaks preventing further connections to the AMI eventually causing clients to no longer connect.
  • If you are using Asterisk 1.4, see Timeout Waiting for Response from Command: StatusAction for a possible cause.

Workaround

If your issue is due to the AMI connection leak bug restart your iSymphony server.

Resolution

Verify that your AMI connection is configured properly. See the Asterisk Server (Vanilla) Installation or the FreePBX, Elastix and PBX in a Flash Installation section for more information.

If your issue is due to the AMI connection leak bug upgrade to the latest version of iSymphony. Updating iSymphony instructions. 

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