Desktop Client V2 cannot connect to iSymphony server and cannot be downloaded from web interface
Problem
The desktop client can't connect to iSymphony even though the correct hostname and port are configured.
In addition to the above issue the desktop client cannot be downloaded from the iSymphony web client.
Cause
If the host name and port are indeed correctly configured, this problem is caused by an incorrect desktop client module on the iSymphony server. The wrong version of the desktop client may be installed or it is missing entirely.
Solution
This problem can be resolved by (re)installing the correct desktop client module on the iSymphony server
Versions 3.4.2 and higher
You may want to use a panel to highlight important steps.
- connect the (remote) shell of the iSymphony server
- stop the iSymphpony server
service iSymphonyServerV3 stop - remove current desktop module
rm -rf /opt/isymphony3/server/modules/desktop - Download the iSymphony server tar for the currently installed version
cd ~/
wget <URL from Download archive> - extract desktop module from tar into iSymphony's module directory
mkdir tmp
tar -C ./tmp -xvf <downloaded file>.tar --strip-components 1
cp -r tmp/modules/desktop /opt/isymphony3/server/modules/
rm -rf tmp - Check ownership of the module
See: Desktop Client Module Installation
- Start iSymphony
service iSymphonyServerV3 start
Related articles
Related articles appear here based on the labels you select. Click to edit the macro and add or change labels.
Unknown macro: contentbylabel. Click on this message for details.
Unknown macro: details. Click on this message for details.